Uploaded image for project: 'Percona Monitoring and Management'
  1. Percona Monitoring and Management
  2. PMM-3417

Inconsistent version option use for proxysql_exporter, mysqld_exporter ,node_exporter

    Details

    • Type: Bug
    • Status: Open
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: 1.17.0
    • Fix Version/s: 2.X
    • Component/s: Builds
    • Labels:
      None

      Description

      proxysql_exporter, mysqld_exporter ,node_exporter -version and --version both works , as per help correct is '-version'proxysql_exporter, mysqld_exporter ,node_exporter -version and --version both works , as per help correct is '-version'

       

       # /usr/local/percona/pmm-client/proxysql_exporter --version
      proxysql_exporter, version  (branch: , revision: )
      build user:         
      build date:         
      go version:       go1.10.1                     
       
      # /usr/local/percona/pmm-client/proxysql_exporter -version
      proxysql_exporter,version  (branch: , revision: )  
      build user:         
      build date:         
      go version:       go1.10.1
      
       
      ./proxysql_exporter -h 2>&1 | grep version
      -version    Print version information and exit.
      

        Smart Checklist

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                lalit.choudhary Lalit Choudhary
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: