PMM-4857 I have created an update for all the "# HELP ..." descriptions that removes the long descriptions and replaces them with the mongodb source metric. I found too many of the metric names were too vague. The generic names too often resembled not one but several source metrics in MongoDB serverStatus etc. output. And/or don't indicate the dimension/label level in them.
These HELP comments are not for general user reading, you only see them if looking at raw prometheus exporter pages. So this is patch for the sake of programmers. They will be able to easily lookup the MongoDB documentation (just cut and paste into google, click) for the metric source from these rewritten help field strings.