Uploaded image for project: 'Percona Monitoring and Management'
  1. Percona Monitoring and Management
  2. PMM-7569

pg_stat_monitor 0.8 release support

    XMLWordPrintable

    Details

      Description

      User story:
      As a PMM user, I need to be able to use PMM with pg_stat-monitor 0.8 version so that I can get the same level of information about PG queries as I get with the 0.6 version

      UI/UX:
      N/A

      Acceptance criteria

      • 0.6, 0.7 and 0.8 versions of pg_stat_statement supported
      • User is able to monitor PG and get the data collected

      Out of scope:

      • collection and the highlight of new fields and data provided by 0.8 version of the plugin

      Suggested implementation:
      1. Rename IP into client_ip for never versions
      2. Check all works well, even buckets
      Most likely as side effect we will support also 0.7.

       

      How to test:
      1. Use this image: perconalab/percona-distribution-postgresql:13.2
      2. Start docker container
      3. Connect into postgres and run query: CREATE EXTENSION pg_stat_monitor;
      4. Check that pg_stat_monitor version is 0.8 by query: SELECT pg_stat_monitor_version();
      4. Add postgres to monitoring by pmm-admin add
      5. Check inventory, here should be QAN PostgreSQL Pgstatmonitor Agent which is running
      6. Check QAN
      7. Check once more with older pg_stat_monitor (0.6.0), image: perconalab/percona-distribution-postgresql:12

      Details:
      TBD

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              roma.novikov Roma Novikov
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Smart Checklist