Uploaded image for project: 'Percona Server'
  1. Percona Server
  2. PS-2938

LP #1169505: SSL connection error after upgrade from 5.5.30-30.1 to 5.5.30-30.2

    Details

    • Type: Bug
    • Status: Done
    • Priority: Low
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None

      Description

      **Reported in Launchpad by Olaf van Zandwijk last update 09-07-2014 09:09:58

      I install Percona server 5.5 from Debian repositories (repo.percona.com). When I upgraded from 5.5.30-30.1 to 5.5.30-30.2, all my SSL-enabled clients were unable to connect. This includes slave threads, etc.

      All clients fail with the error

      ERROR 2026 (HY000): SSL connection error: error:00000001:lib(0):func(0):reason(1)

      Downgrading the server to 5.5.30-30.1 resolves the issue.

      The changelog notes that "Percona Server for MySQL was built with YaSSL which could cause some of the programs that use it to crash. Fixed by building packages with OpenSSL support rather than the bundled YaSSL library." It might be related to this? http://bugs.mysql.com/bug.php?id=61827

        Attachments

          Expenses

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                lpjirasync lpjirasync (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: