Uploaded image for project: 'Percona Server'
  1. Percona Server
  2. PS-3103

LP #1291249: Percona-Server-Shared-55 >= 5.5.36 lacks libmysqlclient.so.18

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Low
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Packaging
    • Labels:

      Description

      **Reported in Launchpad by René Diepstraten last update 30-04-2016 01:55:09

      On several servers, we are running Percona Server 5.5 and php 5.x compiled against Percona-Server-Shared-55 .
      Today we ran into an issue while upgrading Percona-Server-Shared-55 from 5.5.35-rel33.0.611.rhel6.x86_64 to 5.5.36-rel34.0.el6.x86_64 :
      Apache would not start because php was linked against libmysqlclient.so.18 , which in this minor upgrade is renamed to libperconaserverclient.so.18 , thus breaking php.
      If such a change would occur in a minor upgrade, a symlink should be provided to maintain backwards compatibility:
      /usr/lib64/libmysqlclient.so.18.0.0 -> /usr/lib64/libperconaserverclient.so.18.0.0

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              lpjirasync lpjirasync (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: