Uploaded image for project: 'ProxySQL Admin Scripts'
  1. ProxySQL Admin Scripts
  2. PSQLADM-114

Proxysql fails to start

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Pending Release
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.12
    • Component/s: Packaging
    • Labels:
      None
    • Environment:

      Ubuntu 18.04 with all updates.

      Description

      I tried upgrading our test server to the newest 1.4.10-1.1.bionic version. It failed with an error. Then I purged the package. Manually removed all traced of it and tried to reinstall. Same result. Also starting the init script manually leads to the error below.

       

      Reading package lists... Done
      {{Building dependency tree }}
      Reading state information... Done
      The following NEW packages will be installed:
      {{ proxysql}}
      0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      Need to get 0 B/1438 kB of archives.
      After this operation, 4669 kB of additional disk space will be used.
      Selecting previously unselected package proxysql.
      (Reading database ... 113429 files and directories currently installed.)
      Preparing to unpack .../proxysql_1.4.10-1.1.bionic_amd64.deb ...
      Unpacking proxysql (1.4.10-1.1.bionic) ...
      Processing triggers for ureadahead (0.100.0-20) ...
      Setting up proxysql (1.4.10-1.1.bionic) ...
      Created symlink /etc/systemd/system/multi-user.target.wants/proxysql.service -> /lib/systemd/system/proxysql.service.
      Job for proxysql.service failed because the control process exited with error code.
      See "systemctl status proxysql.service" and "journalctl -xe" for details.
      invoke-rc.d: initscript proxysql, action "start" failed.
      * proxysql.service
      {{ Loaded: loaded (/lib/systemd/system/proxysql.service; enabled; vendor preset: enabled)}}
      {{ Active: failed (Result: exit-code) since Fri 2018-09-21 18:24:39 CEST; 6ms ago}}
      {{ Process: 45375 ExecStart=/etc/init.d/proxysql start (code=exited, status=1/FAILURE)}}Sep 21 18:24:38 max1.pjm.dom systemd[1]: Starting proxysql.service...
      Sep 21 18:24:38 max1.pjm.dom proxysql[45375]: /etc/init.d/proxysql: Zeile 25: ulimit: core file size: Kann die Grenze nicht ändern: Vorgang nicht zulässig
      Sep 21 18:24:39 max1.pjm.dom proxysql[45375]: Starting ProxySQL: su: must be run from a terminal
      Sep 21 18:24:39 max1.pjm.dom proxysql[45375]: FAILED!
      Sep 21 18:24:39 max1.pjm.dom systemd[1]: proxysql.service: Control process exited, code=exited status=1
      Sep 21 18:24:39 max1.pjm.dom systemd[1]: proxysql.service: Failed with result 'exit-code'.
      Sep 21 18:24:39 max1.pjm.dom systemd[1]: Failed to start proxysql.service.
      dpkg: error processing package proxysql (--configure):
      {{ installed proxysql package post-installation script subprocess returned error exit status 1}}
      Processing triggers for systemd (237-3ubuntu10.3) ...
      Processing triggers for ureadahead (0.100.0-20) ...
      Errors were encountered while processing:
      {{ proxysql}}
      needrestart is being skipped since dpkg has failed
      E: Sub-process /usr/bin/dpkg returned an error code (1)

        Attachments

          Activity

            People

            • Assignee:
              evgeniy.patlan Evgeniy Patlan
              Reporter:
              mosi0815 Ralph Moser
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - Not Specified
                Not Specified
                Logged:
                Time Spent - 5 hours, 30 minutes
                5h 30m