Uploaded image for project: 'Percona XtraBackup'
  1. Percona XtraBackup
  2. PXB-497

LP #1667610: Wrong dependency for MD5

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None

      Description

      **Reported in Launchpad by Daniƫl van Eeden last update 02-03-2017 07:19:19

      This was introduced by the fix for:
      #1644018 No dependency check in RPM package for Perl Digest::MD5

      2.4.6 adds a dependency on perl-MD5
      $ repoquery --requires percona-xtrabackup-24-2.4.6-1.el6.x86_64 | egrep '^perl'
      perl(DBD::mysql)
      perl-MD5
      $ repoquery --requires percona-xtrabackup-24-2.4.5-1.el6.x86_64 | egrep '^perl'
      perl(DBD::mysql)

      This is correctly indicated by the release notes.
      https://www.percona.com/doc/percona-xtrabackup/2.4/release-notes/2.4/2.4.6.html

      But I don't see where this dependency is defined in percona-xtrabackup.git:
      $ git grep perl-MD5
      storage/innobase/xtrabackup/doc/source/installation/yum_repo.rst: CentOS 5 and CentOS 6 ``perl-MD5`` package is required from the same
      storage/innobase/xtrabackup/doc/source/release-notes/2.3/2.3.7.rst: will now require ``perl-MD5`` package to be installed from EPEL repositories
      $ cat XB_VERSION
      XB_VERSION_MAJOR=2
      XB_VERSION_MINOR=3
      XB_VERSION_PATCH=6
      XB_VERSION_EXTRA=
      $ grep '^Requires:' ./storage/innobase/xtrabackup/utils/percona-xtrabackup.spec
      Requires: perl(DBD::mysql), rsync
      Requires: percona-xtrabackup = %

      {version}

      -%

      {release}

      Requires: /usr/bin/mysql

      So I can't fix this by sending a pull request. Looks like the spec file in the repo is outdated.

      My problem is that perl-MD5 is deprecated:
      $ rpm -ql perl-MD5
      /usr/share/doc/perl-MD5-2.03
      /usr/share/doc/perl-MD5-2.03/Changes
      /usr/share/doc/perl-MD5-2.03/README
      /usr/share/man/man3/MD5.3pm.gz
      /usr/share/perl5/vendor_perl/MD5.pm
      $ head -1 /usr/share/doc/perl-MD5-2.03/README
      This module is depreciated. Please use Digest::MD5 instead.

      I do have Digest::MD5 installed:
      $ rpm -qf /usr/lib64/perl5/Digest/MD5.pm
      perl-5.10.1-141.el6_7.1.x86_64

      So probably the spec file should be changed from:
      Requires: perl-MD5

      To:
      Requires: perl(Digest::MD5)

      This is on CentOS 6.8

        Smart Checklist

          Attachments

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              lpjirasync lpjirasync (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: