Uploaded image for project: 'Percona XtraBackup'
  1. Percona XtraBackup
  2. PXB-741

LP #1526467: xtrabackup crashes with docker

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      **Reported in Launchpad by Rémy Phelipot last update 11-07-2016 10:00:45

      MariaDB is running in a docker container and a volume is mounted on the host for the database files. I'm trying to backup the database with xtrabackup but I've got this error:

      xtrabackup --backup --target-dir=test --host=10.10.10.96 --user=root
      151215 17:24:39 version_check Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_group=xtrabackup;host=10.10.10.96;port=3306;mysql_socket=/var/run/mysqld/mysqld.sock' as 'root' (using password: YES).
      151215 17:24:39 version_check Connected to MySQL server
      151215 17:24:39 version_check Executing a version check against the server...
      151215 17:24:39 version_check Done.
      151215 17:24:39 Connecting to MySQL server host: 10.10.10.96, user: root, password: set, port: 3306, socket: /var/run/mysqld/mysqld.sock
      Using server version 10.0.21-MariaDB-1~jessie
      2015-12-15 17:24:39 7fec27b46780 InnoDB: Assertion failure in thread 140652255143808 in file backup_copy.cc line 648
      InnoDB: Failing assertion: realpath(first, real_first) != NULL
      InnoDB: We intentionally generate a memory trap.
      InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
      InnoDB: If you get repeated assertion failures or crashes, even
      InnoDB: immediately after the mysqld startup, there may be
      InnoDB: corruption in the InnoDB tablespace. Please refer to
      InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
      InnoDB: about forcing recovery.
      17:24:39 UTC - xtrabackup got signal 6 ;
      This could be because you hit a bug or data is corrupted.
      This error can also be caused by malfunctioning hardware.
      We will try our best to scrape up some info that will hopefully help
      diagnose the problem, but since we have already crashed,
      something is definitely wrong and this may fail.

      Thread pointer: 0x0
      Attempting backtrace. You can use the following information to find out
      where mysqld died. If you see no messages after this, something went
      terribly wrong...
      stack_bottom = 0 thread_stack 0x10000
      xtrabackup(my_print_stacktrace+0x2e) [0x94eebe]
      xtrabackup(handle_fatal_signal+0x262) [0x90fcf2]
      /lib/x86_64-linux-gnu/libpthread.so.0(+0x10340) [0x7fec27722340]
      /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x39) [0x7fec25e86cc9]
      /lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7fec25e8a0d8]
      xtrabackup() [0x5a9f03]
      xtrabackup(get_mysql_vars(st_mysql*)+0x42d) [0x5a639d]
      xtrabackup(xb_init()+0x12b) [0x59b67b]
      xtrabackup(main+0x641) [0x57e101]
      /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7fec25e71ec5]
      xtrabackup() [0x5922c6]

      Please report a bug at https://bugs.launchpad.net/percona-xtrabackup

      I've tried to execute this command inside the container and it work successfully, but it seems impossible to save the database from the host or another container. I've also tried unsuccessfully to set the --datadir option to the host directory .

      Can someone reproduce this issue? Do you have a solution?

        Smart Checklist

          Attachments

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              lpjirasync lpjirasync (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: