Uploaded image for project: 'Percona XtraDB Cluster'
  1. Percona XtraDB Cluster
  2. PXC-1263

LP #1084309: Dependency Conflict between Percona-XtraDB-Cluster-shared and Percona-Server-shared-compat

    Details

      Description

      **Reported in Launchpad by Nathan West last update 22-11-2013 06:58:47

      Hello,

      I've installed Percona-XtraDB-Cluster-5.5.28 on CentOS 6.3 and have it up and running successfully. (using yum)

      I've attempted to install the percona-toolkit but have had issues resolving some dependencies. I was able to resolve all of them except for perl(DBD::mysql) Log is below.

      No other mysql version had been installed previously.

      I tried to softlink libmysqlclient.so.16, following a forum post I found but that didn't work. I also tried to install the Percona-server-shared-compat library, but that erred with other dependency issues.

      [root@percona1 ~]# yum install percona-toolkit
      Loaded plugins: fastestmirror, presto
      Loading mirror speeds from cached hostfile

      • base: dist1.800hosting.com
      • epel: mirror.steadfast.net
      • extras: centos.mirrors.tds.net
      • updates: mirror.cisp.com
        Setting up Install Process
        Resolving Dependencies
        --> Running transaction check
        ---> Package percona-toolkit.noarch 0:2.1.7-1 will be installed
        --> Processing Dependency: perl(DBD::mysql) >= 1.0 for package: percona-toolkit-2.1.7-1.noarch
        --> Running transaction check
        ---> Package perl-DBD-MySQL.x86_64 0:4.013-3.el6 will be installed
        --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
        --> Processing Dependency: libmysqlclient.so.16()(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
        --> Running transaction check
        ---> Package Percona-Server-shared-51.x86_64 0:5.1.66-rel14.1.496.rhel6 will be installed
        --> Processing Conflict: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 conflicts Percona-Server-shared-51
        --> Processing Conflict: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 conflicts mysql-libs
        --> Finished Dependency Resolution
        Error: Percona-XtraDB-Cluster-shared conflicts with Percona-Server-shared-51
        You could try using --skip-broken to work around the problem
        • Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
          1:Percona-XtraDB-Cluster-client-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql: 1:Percona-XtraDB-Cluster-client-5.5.28-23.7.369.rhel6.x86_64
          1:Percona-XtraDB-Cluster-server-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql-server: 1:Percona-XtraDB-Cluster-server-5.5.28-23.7.369.rhel6.x86_64
          1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql-libs: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64

        Smart Checklist

          Attachments

            Activity

              People

              • Assignee:
                krunal.bauskar Krunal Bauskar
                Reporter:
                lpjirasync lpjirasync (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: