Uploaded image for project: 'Percona XtraDB Cluster'
  1. Percona XtraDB Cluster
  2. PXC-2197

Modified the SST Documentation to Include Package Dependencies for Percona XtraBackup (PXB).

    XMLWordPrintable

    Details

      Description

      The wording in the documentation leaves it open to interpretation regarding strict dependencies:

      XtraBackup SST Dependencies
      Although any current version of Percona XtraBackup may be compatible with any current version of Percona XtraDB Cluster, there are certain differences that may break compatibility. As a result, starting from Percona XtraDB Cluster 5.6 every version is tested against a specific Percona XtraBackup version only:
      
      Percona XtraDB Cluster 5.6 requires Percona XtraBackup 2.3
      Percona XtraDB Cluster 5.7 requires Percona XtraBackup 2.4
      
      Other combinations are not guaranteed to work.
      

      Installing the wrong version of percona-xtrabackup will remove the cluster.

      Galera, which uses rsync or mysqldump does not have a package dependency.

        Attachments

          Activity

            People

            Assignee:
            borys.belinsky Borys Belinsky (Inactive)
            Reporter:
            ceri.williams Ceri Williams
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - Not Specified
                Not Specified
                Logged:
                Time Spent - 3 hours
                3h

                  Smart Checklist